To follow along with this book, you’ll need the following:

  • A Mac running macOS Catalina (10.15) or later.

  • Xcode 12 or later. Xcode is the main development tool for iOS. You’ll need Xcode 12 or later to make use of SwiftUI and the latest features explained throughout the book. You can download the latest version of Xcode from Apple’s developer site here: apple.co/2asi58y.

Note: The code covered in this book was developed and tested with Swift 5.2, macOS Catalina and Xcode 11.5 — so even though you can work with slightly earlier versions of them, we encourage you to update to those versions to follow along the book without unexpected errors.

Have a technical question? Want to report a bug? You can ask questions and report bugs to the book authors in our official book forum here.

Have feedback to share about the online reading experience? If you have feedback about the UI, UX, highlighting, or other features of our online readers, you can send them to the design team with the form below:

© 2021 Razeware LLC