Home iOS & Swift Books iOS Animations by Tutorials

i
What You Need Written by Marin Todorov

To follow along with the tutorials in this book, you’ll need the following:

  • A Mac running macOS Monterey or later. You’ll need this to be able to install the latest version of Xcode and use Xcode previews.
  • Xcode 13.0 or later. Xcode is the main development tool for iOS. You’ll need Xcode 13.0 or later for all tasks in this book. You can download the latest version of Xcode from Apple’s developer site here: https://developer.apple.com/develop/
  • Basic knowledge of Swift and iOS development. This book is about animations specifically; to understand the animation code and how the accompanying demo projects work you will need at least a basic understanding of Swift and UIKit.

If you want to try things out on a physical iOS device, you’ll need a developer account with Apple, which you can obtain for free. However, all the sample projects in this book will work just fine in the iOS Simulator bundled with Xcode, so the developer account is completely optional.

Have a technical question? Want to report a bug? You can ask questions and report bugs to the book authors in our official book forum here.

© 2022 Razeware LLC