There is an updated version of this course available, created for Kotlin 1.3, Android 5.0, Studio 4.0. View Latest Version